Contents View

Top  Previous  Next

 

Any files selected in the File List view are displayed in the Contents view.

 

Summary Tab

 

The summary tab simply provides a summary of the latest search:

 

SummaryTab

 

Depending on the type of search (e.g. File name search, content search, index search etc.) different information is displayed. In the above example it shows the statistics for:

 

Found

the count and size of all the files that matched both the file name and containing text criteria and are therefore displayed in the File List View.

Text

the total number of hits found in the text of the files

Searched

the count and size of all files that were searched after matching the file name criteria (only applicable for content searches)

Pending Search

the number of files that remain to be searched (when the search has finished this value should always be 0).

Checked

the count and size of all files that were checked against the file name criteria

Status

the search status and total running time

Completed

The time the search finished

 

The Summary tab also shows any error, warnings, and informational data generated during the search to help understand the results of the search. In the above example there is a warning that the content search was case sensitive and additional information showing that 5,164 files were excluded based on their name (ie the name did not match the File name field) and 3,102 files excluded based on the contents of file (ie the contents did not match the Containing Text field).

 

Hits Tab

 

When searching through the contents of files the Hits tab displays the found information, ie the hits, from each of the selected files (click Select All from the Edit menu to see hits for all files). For non-content searches only the file name is displayed.

 

ContentsView

 

Lines that contain the search text are shown with the hit text highlighted in a different color. The highlight color is by default blue but this can be changed to any color through Set Highlight Colour on the Edit menu.

 

The expansion buttons next to the lines of text can be used to show surrounding lines of text as shown below.

 

ContentsView_Expand

 

The number of surrounding lines can be set via the Configuration dialog.

 

The file can be opened at the specified line by either double-clicking on the line or right-clicking on the line to bring up the context menu and selecting "Open in New Window...". To open the file with an external editor (e.g. Notepad++) select "Open in External Editor..." from the context menu. For more information see Editor Settings.

 

Note: When displaying file contents the line number of each line found within the file is also displayed. This line number is estimated by counting end of line markers within the file and therefore if the file contains non-text information then the line numbers may not be accurate.

 

 

Text Tab

 

To view the hits in context of the actual file use the Text tab. The Text tab embeds the Internal File Viewer into the Contents View for faster previewing of files:

 

TextTab

 

To open the file in a larger window choose 'Open in New Window...' option from the context menu or use the Ctrl+Enter key combination.

 

Note: By default FileLocator Pro will open the file in Text tab when double-clicking on a hit in the Hits tab. This default behaviour can be changed in the Editor Settings page.

 

 

Thumbnails Tab

 

When searching for pictures, or other graphical files, the Thumbnail tab provides a preview of the selected files.

 

ContentsView_Thumbnails

 

 

Reports Tab

 

The reports tab provides an easy way to export, print, or summarize search data.

 

ReportsTab

 

More information on FileLocator Pro's reporting feature is available in the Reports topic.

 

 

Hiding/Docking the View

 

If displaying of content information is not important then it is often more efficient to hide the contents view, especially with very large file selections. To hide the contents view either select 'Hide Contents View' from the Contents View context menu or select the 'Window->Contents View->Hide' menu option.

 

To display the contents view below the file list view either select 'Dock Below' from the Contents View context menu or select the 'Window->Contents View->Dock Below' menu option.

 

 

Printing

 

The Hits tab is the printable area of the application and prints whatever the user has selected in the File List view. To print this view click Print or Print Preview from the File menu.


Copyright © 2016 Mythicsoft Ltd. All rights reserved.
Help file version: 8.0

PDF and CHM versions of this help file are available here:
http://mythicsoft.com/filelocatorpro/help