Hinweise und Tipps

Top  Previous  Next

 

Nach den mehrfachen Filetypen suchen

Sie können mehrere Files suchen wenn Sie reguläre Ausdrücke oder DOS Ausdrücke verwenden. z.B.

die Filetypen suchen .cpp, .h, .c, .INL der reguläre Ausdruck wird sein:

\.(cpp|h|c|INL)$

 

ODER, alternativ als einen DOS Ausdruck wird es sein:

*.cpp;*.h;*.c;*.INL

 

Filetypen ausschließen

Präfix DOS Ausdruck mit NICHT: um die bestimmten Filetypen von der Suche ausschließen.  Zum Beispiel, können Sie alles außer den COM and EXE Files suchen wenn Sie den Filenamen zu dem DOS Ausdruck setzen:

NOT:*.exe;*.com

 

Mehrfache Lokalisierunge suchen

FileLocator Pro kann  mehrfache Ordnerwege suchen. In dem 'Schau in' Feld trennen Sie jeden Ordner mit einem Semikolon, z.B.

c:\winnt;c:\tmp

 

Ausdrücke in einem Hereinschauen Feld

Ausdrücke werden auf den Ordnerwegen unterstützt. Um die Eigenschaft zu benutzen, benutzen Sie den Ausdruck Drop-Down Liste, die sich neben dem Schau In Feld befindet. Der Ausdruck ist nicht auf dem ganzen Weg, aber auf den Wegteilen verarbeitet, z.B.

c:\usr\dev\.*\release

 

wird alle Ordner, die "release" genannt werden passen, zwei Levels unter aus dem "c:\usr\dev" Ordner.

 

FileLocator Pro aus Windows Explorer einführen

FileLocator Pro kann mit Windows Shell durch die Shell Erweiterungen Einstellungen integriert werden. Zum Beispiel, wenn man Files und Ordner in Windows Explorer durchsuchen, kann man  FileLocator Pro einführen von Rechtsklicken den Ordner und  'FileLocator Pro...' aus dem Kontextmenü des Ordners wählen  oder Verknüpfung Tastekombienierung benutzen Ctrl+F.

 

Häufigste Suchen

Sparen Sie Ihre häufigste Suchekriterien als ein SRF File und setzen Sie eine Verknüpfung zu dem File in Startmenü. Dann wenn Sie die Verknüpfung öffnen, FileLocator Pro wird mit Ihren häufigsten Sucheoptionen beginnt.

 

Bemerkung: Sichern Sie sich, dass FileLocator Pro mit SRF Files in den Shell Integration Einstellungen verbunden wird.

 

Automatische Werte durch die Anweisungsleine spezifizieren

Sie können die initialen Werte für FileLocator Pro spezifizieren durch Anweisungsleineparameter. Es gibt sogar eine Option, die GUI (Graphical User Interface) ausschaltet und die Ergebnisse direkt zu einem File spart. Sie ist verwendbar wenn man FileLocator Pro mit anderen Anwendungssoftwaren integriert. Um die Liste von den gültigen Anweisungsleineparameter zu sehen, gehen Sie zu dem  "Hilfe->Anweisungsleineparameter" Dialog (oder führen Sie FileLocatorPro.exe -h aus).

 

Performance Ergebnis von Wortumbruch

Wortsumbruch ist teuer, besonders wenn man einen großen Inhalt zeigt. Wenn die Inhaltssicht langsam ist, vielleicht sollen Sie den Wortsumbruch ausschalten.

 

Performance Ergebnis von Inhaltssicht

Wenn Sie eine große Zahl von Files wählen und brauchen nicht den Sucheninhalt dieser Files zu sehen, es ist schneller die"Inhaltssicht"  durch die "Fester->Inhaltssicht->Verstecken" Menüoption auszuschalten.

 

Leistungseffekt von verzögerter Suche

Die verzögerte Suche von FileLocator Pro funktioniert in einem zweiphasigen Prozess. Die erste Phase sammelt eine Liste an Dateien, welche auf das Dateinamenskriterium zutreffen. Die zweite Phase durchsucht die Inhalte der in der ersten Phase gefundenen Dateien. Wenn in der ersten Phase viele Dateien gefunden wurden, benutzt FileLocator Pro eventuell einen signifikanten Anteil der Speicherressourcen, um die Liste der Dateien zu erhalten.

 

Deswegen gibt es die Option Unmittelbar in den Sucheinstellungen, um FileLocator Pro anzuweisen, die Inhalte der Dateien zu durchsuchen, sobald der Dateiname zutrifft, wodurch die Erhaltung der internen Dateienliste vermieden wird. Der einzige Nachteil der unmittelbaren Suche ist, dass FileLocator Pro keine Fortschrittsanzeige anzeigen kann. Benutzen Sie dieses Feature für ein speichereffizienteres Inhaltssuchen einer großen Gruppe von Dateien (d. h. > 1.000.000), normalerweise ist dies NICHT notwendig.

 

FileLocator Pro wird automatisch zur unmittelbaren Suche wechseln, wenn es eine sehr große Suchanfrage entdeckt.

 

Bemerke: Die mehrphasige Suchoption ist ein Kompromiss zwischen den beiden Methoden und ist jetzt die standardmäßige Suchmethode.

 

Unix und Mac Files suchen

Unix and Mac Textfile Formaten verwenden einen verschiedenen Ablauf um das Leineende zu markieren. Windows und DOS verwenden einen Symbolaublauf CR-LF (Carriage Return - Line Feed) aber Unix verwendet nur LF und Mac verwendet nur CR. Um  FileLocator Pro zu instruieren und um nach den alternativen EOL (das Leineende) Abläufen zu suchen, gehen Sie in die Konfigurierungeinstellungen (durch die Menüoption "Tools->Konfigurierung") und wählen Sie Zeichenverarbeitung.

 

Reguläre Ausdrücke testen

Testen Sie Ihre reguläre Ausdrücke durch die "Tools->"Reguläre Ausdrücke Tester" Menüoption.

 

 

 

Mehr Informationen können Sie online in Mythicsoft Wissensbasis finden: http://www.mythicsoft.com/kb.

 

 


Copyright © 2016 Mythicsoft Ltd. All rights reserved.
Help file version: 8.0

PDF and CHM versions of this help file are available here:
http://mythicsoft.com/filelocatorpro/help